|

Microsoft Excel trop compliqué? Voici 10 formules utiles ou intéressantes sur Excel, à retenir facilement et à appliquer dans tous vos tableaux. Le langage "officiel" étant assez hermétique, le mieux est encore de suivre chaque exemple et de l'appliquer sur Excel en même temps que vous lisez cet article.

Microsoft Excel est le logiciel de tableur par excellence. Loué pour sa puissance par les uns, il paraît tout de même un peu effrayant pour la plupart de ceux qui l'utilisent pour la première fois. Ce programme tentaculaire sait presque tout faire et ses possibilités sont nombreuses. Avec le pack office 2013, ce programme gagne encore en puissance.

La somme simple (SOMME)

Elle permet d'additionner plusieurs données chiffrées, comme à l'école. Il existe deux façons de faire.

La première permet d'additionner des cases qui se suivent (une colonne ou une rangée) =SOMME(première case:dernière case) dans la case où vous souhaitez voir apparaître le résultat.

Variante: Cette formule permet aussi d'additionner tous les chiffres contenus dans un cadre particulier (sur plusieurs colonnes et plusieurs rangées), en prenant pour première case celle la plus "en haut à gauche", et comme dernière case celle la plus "en bas à droite".

Dans nos exemples suivants, "première case:dernière case" sera désigné par "plage_cellules"

La seconde méthode permet d'additionner des cases individuellement (sans relation) =SOMME(case1;case2;case3;case4) dans la case où vous souhaitez voir apparaître le résultat.

Démonstration par l'exemple:

Somme Excel

Pour additionner le contenu de la première colonne, inscrivez dans la case de votre choix =SOMME(A1:A5). Pour additionner l'ensemble des chiffres du tableau, inscrivez dans la case de votre choix =SOMME(A1:B5). Pour additionner seulement les cases portant un nombre négatif, inscrivez dans la case de votre choix =SOMME(A1;B3;B5).

La somme en fonction d'un critère déterminé (SOMME.SI)

Notez que cette fonction n'est disponible que pour Excel 2007 et versions plus récentes.

Un tableau peut se présenter sous la forme d'une liste de plusieurs données n'ayant pas forcément de liens entre elles. Si la liste est longue, il peut être pénible de retrouver tous les éléments identiques pour les additionner un par un. Pour cela, on peut demander à Excel de retrouver toutes ces cases spécifiques et d'en faire la somme grâce à la formule =SOMME.SI(plage_cellules;"critère";somme_plage). Le "critère" est la condition à chercher dans le tableau. La plage_cellules est la plage de cellules contenant le critère à retenir. La somme_plage est la plage de cellules où se trouvent les nombres à additionner.

Démonstration par l'exemple:

Somme Si Excel

Dans cet exemple, le critère à rechercher est "rouge". Pour calculer le nombre de "rouge" uniquement, inscrivez dans la case de votre choix la formule suivante: =SOMME.SI(B1:B5;"rouge";A1:A5).

 

La somme en fonction de plusieurs critères (SOMME.SI.ENS)

Un tableau peut comporter de multiples informations. Excel peut additionner des données chiffrées en fonction de plusieurs critères grâce à une formule spéciale: =SOMME.SI.ENS(somme_plage;plage_critère1;critère1;plage_critère2;critère2;….). La somme_plage est la plage de cellules où se trouvent les nombres à additionner. La plage_critère1 représente la plage de cellules contenant les données sur le premier critère, la plage_critère2 étant bien entendu associée au second critère, et ainsi de suite. Le critère1 est le premier critère à chercher dans le tableau, etc.

Démonstration par l'exemple:

Tableau Excel

Pour trouver le nombre de points récoltés par les hommes de l'équipe jaune, inscrivez dans la case de votre choix la formule suivante: SOMME.SI.ENS(D1:D13;C1:C13;C1;B1:B13;B1)

Variante: Vous n'êtes pas obligé de sélectionner la première et la dernière case de la colonne exactement, vous pouvez sélectionner une colonne entière. Au lieu de B1:B13, indiquez juste B:B.

La somme d'évènements fondée sur un critère (NB.SI)

Au rayon Statistiques, il est parfois intéressant de savoir combien de fois un évènement donné se répète dans une colonne. Pour cela, on emploie la fonction suivante: =NB.SI(plage_cellules;"critère"). La plage_cellules représente la plage de cellules contenant les données chiffrée où chercher. Le critère est le premier critère à chercher dans le tableau.

Démonstration par l'exemple:

Dans le tableau précédent, vous souhaitez savoir combien de femmes participaient au jeu. Inscrivez dans la case de votre choix, la formule suivante: =NB.SI(B1:B13;"Femme")

La somme d'évènements fondée sur plusieurs conditions (SOMMEPROD)

Cette formule permet d'extraire une statistique afin de répondre à la question suivante: combien de fois ces conditions spécifiques sont-elles réunies dans mon tableau? Réponse: =SOMMEPROD((plage_critère1="critère1")*(plage_critère2="critère2"))

La plage_critère1 représente la plage de cellules contenant les données sur le premier critère, la plage_critère2 étant bien entendu associée au second critère, et ainsi de suite. Le critère1 est le premier critère à chercher dans le tableau, etc.

Démonstration par l'exemple:

En prenant le tableau précédent, cette formule permet de dire combien d'hommes faisaient partie de l'équipe jaune par exemple. Pour cela, inscrivez dans la case de votre choix la formule suivante: =SOMMEPROD((B1:B13="Homme")*(C1:C13="jaune"))

La somme d'évènements compris entre deux valeurs précises (SOMMEPROD)

Vous l'aurez compris, la SOMMEPROD est plutôt un outil statistique puisqu'elle se concentre sur le nombre de fois où certaines conditions sont remplies en même temps. Elle permet de retrouver dans un tableau le nombre de fois où les données chiffrées sont comprises entre deux valeurs précises, grâce à la formule suivante: =SOMMEPROD(plage_cellules>=minimum)*(plage_cellules<=maximum)).

La plage_cellules représente la plage de cellules contenant les données chiffrées où il faut chercher. Minimum et Maximum sont les deux valeurs entre lesquelles chercher notre résultat.

Démonstration par l'exemple:

Dans notre tableau-exemple précédent, nous devons trouver le nombre de joueurs qui ont marqué entre 150 et 200 points. Pour cela, inscrivez dans la case de votre choix la formule suivante: =SOMMEPROD((D1:D13>=150)*(D1:D13<=200))

La moyenne (MOYENNE)

Inutile de rappeler ici ce qu'est une moyenne. Elle est, de plus, très simple à obtenir avec la formule suivante: =MOYENNE(plage_cellules)

La plage_cellules représente la plage de cellules contenant les données chiffrées où chercher.

Démonstration par l'exemple:

Moyenne Excel

Pour calculer la moyenne de tous ces nombres, inscrivez dans la case de votre choix la formule suivante: =MOYENNE(A1:A6)

 

Le maximum et le minimum (MAX et MIN)

Dans une trop large gamme de données, il peut être fastidieux de chercher le plus grand ou le plus petit résultat chiffré. Heureusement, Excel a une formule pour chercher à votre place. Elle est très simple à appliquer puisqu'elle s'affiche de la façon suivante:

=MAX(plage_cellules)

=MIN(plage_cellules).

La plage_cellules représente la plage de cellules contenant les données chiffrées où chercher.

Variante: vous pouvez appliquer la recherche à plusieurs plages de cellules. Les formules deviennent alors:

=MAX(plage_cellules1;plage_cellules2)

=MIN(plage_cellules1;plage_cellules2)

Démonstration par l'exemple:

Dans le tableau précédent, vous cherchez la plus grande valeur chiffrée. Inscrivez dans la case de votre choix la formule suivante: =MAX(A1:A6). Si vous cherchez la plus petite valeur chiffrée, inscrivez: =MIN(A1:A6)

Bien entendu, cette formule trouve son intérêt dans les très grands tableaux.

En bref

Même si elles peuvent sembler assez hermétiques au premier abord, ces formules Excel vont vous permettre de gagner un temps fou si vous utilisez ce logiciel de manière fréquente.

Vous recherchez une alternative gratuite à Excel? Voici 6 excellentes alternatives à la suite bureautique Office de Microsoft.

 

Téléchargez Microsoft Office 2013

A lire aussi:

Microsoft Office 2013 ou Office 365? Les raisons du choix

Microsoft Office 2013: les 5 nouveautés à retenir

[Article mis à jour le 15 mai 2014]

Commentés

  • Twitted by SoftonicFR |
    25/10/10
    Twitted by SoftonicFR

    [...] This post was Twitted by SoftonicFR [...]

  • youcef |
    08/12/10
    youcef

    j'ai un question svp combien de chiffre contient la case d'excel? svp je besoin la réponse toute suite merçi

  • coeuret |
    11/12/10
    coeuret

    sur excel, dans une colonne F4:F51 j'ai 48 chiffres. Je recherche à additionner que les 25 plus grands résultats sur les 48 en F53. Impossible de trouver une formule.

    merci de me donner un coup de pouce.

  • Bonjour |
    05/11/12
    Bonjour

    Bonjour j'ai une question comment fait-on après avoir sélectionner un tableau pour le garder??? SVP j'ai besoin de le savoir au plus vite...

  • Bonjour |
    05/11/12
    Bonjour

    Trop tard j'ai trouver toute seul merci quand meme ou pas...

  • yannah |
    09/01/13
    yannah

    comment fait on pour calculer une puissance SVP j'ai besoin de le savoir au plus vite merci.

  • David |
    16/01/13
    David

    Bonjour, J'aimerais faire un tableau d'addition (Commande) et un second qui cumule les additions (CA) sont soustraire. elle garderais la dernière somme enregistrée. Je m'explique : Le 1er tableau me servirait à enregistrer des commandes cela se répercutera directement sur un tableau CA. Cependant, le fait de changer régulièrement de commande modifie mon tableau CA. J'aimerais que mon tableau CA n'enregistre que du positif. Est ce possible ?

  • sundjee |
    25/01/13
    sundjee

    je voudrais calculer la moyenne de cinq chiffres similaires(plus ou moins égales) dans une colonne de dix chiffres.C'est a dire pouvoir choisir les cinq chiffres similaires ensuite calculer leur moyenne

  • METAYER PASCAL |
    14/03/13
    METAYER PASCAL

    Bonjour,

    J' ai une question à poser: J 'ai une suite de nombre positif et négatif sur une même ligne et je voudrais pouvoir additionner UNIQUEMENT les nombres négatifs . existe t il une solution ? L 'addition de ces nombres négatifs s' inscrirait dans une cellule. Ex : +2 -1 +16 -4 +1 +1 -6 donnerait comme résultat -11 Merci par avance pour votre aide.

  • badibanga |
    28/03/13
    badibanga

    merci mais il faut aller plus en profondeur et avec beaucoup des clarté merci

  • sarko |
    15/04/13
    sarko

    Bonjour, comment affiche la valeur la plus repetée+la plus grande sur une case choisi j'ai utilise une fonction =INDEX(E3:G3;MODE(EQUIV(E3:G3;E3:G3;1))) mais quand il ya deux valeur repeté meme nombre de fois il ya un erreur par exemple si il il ya 1 2 3 2 4 4 je veux affiché 4 malgré il y a 2 repete merci

  • L2nul |
    03/05/13
    L2nul

    @metayer : j'ai une solution qui fonctionne pour les colonnes (t'auras juste à l'adapter pour les lignes ou tu transforme ta ligne en colonne c'est toi qui voit) : mettons que tes valeurs sont dans les cellules A1 jusqu'à A10. Tu rentre : =somme.si(A1:A10;"<0";A1:A10) Je m'explique : somme.si est une somme sous conditions : le premier A1:A10 c'est la plage qui va être additionnée le "<0" c'est la condition le deuxième A1:A10 c'est la plage sur laquelle on applique la condition

    En gros, il regarde A1. S'il est positif, il ne garde pas A1. S'il est négatif, il garde A1. Il regarde A2. S'il est positif, il ne le garde pas. Sinon, il le garde. etc... jusqu'à A10. Quand il a fini, il additionne toutes les cellules qu'il a gardées.

  • vlucas |
    16/05/13
    vlucas

    Bonjour, je chercher à additionner des lignes dont une donnée se répète sur une colonne.J'ai bien compris la notion de SOMME.SI, par contre, mes valeurs ne sont pas connues à l'avance, il s'agit de bénéficiaires qui changent à chaque export. Quelle formule utiliser pour additionner toutes les lignes d'un même bénéficiaire (qui change à chaque fois).

  • C |
    06/09/13
    C

    bonsoir ,lorsque j’utilise des données avec +- dans excel l'histogramme ne s'affiche pas??

  • eric |
    11/09/13
    eric

    bonjour, comment additionner en colonne "C" les données des colonnes "A" et "B" pour chaque ligne Merci

  • |
    29/10/13

    j'ai un resultat comme suit 123,87 je veux une formule qui prend le chiffre avant la virgule et une autre qui prend le chiffre apres la virgule merci de repondre par mail:expedition2@international-nursery.com

  • malinoise |
    04/11/13
    malinoise

    Bonjour -Dans un compte d'association, j'ai les colonnes Entrées, Sorties, Solde - Comment faire pour que la colonne Solde se mette à jour au fur et à mesure que je porte une opération dans la colonne Entrées ou Sorties ? Merci -Charles -

  • fati.sabouha |
    22/11/13
    fati.sabouha

    bonjour comment je peut calculer la somme des noms dans le cas où j ai un nom répété plusieurs fois je dois le compter un seule fois et merci

  • achillocesar |
    19/02/14
    achillocesar

    bonjour, chère amis, SALUT LES GA

    J'ai des soucis pour connaitre dans une plage de numéro la fréquence de chacun de ces numéros. exemple:

    je dispose ce champs de numéro à lisser du n° de la plus grande valeur apparue dans ce même champs, au n° de la plus petite valeur de apparue dans ce même champs de numéros.voici un champs de n° Merci de m'avoir aidé.

    44 89 76 60 44 46 47 21 66 61 35 12 69 25 25 70 80 51 52 65 21 53 8 70 36 35 37 59 56 11 60 79 65 34 51 18 63 24 47 81 72 14 45 90 47 24 54 45 49 84 39 82 71 48 6 15 24 69 18 45 42 66 23 79 34 41 56 79 11 76 90 45 46 6 9 55 83 20 65 86 66 2 70 22 53 8 70 36 35 37 59 27 72 32 63 72 63 29 70 25 53 82 7 20 78 65 20 6 2 56 25 68 20 65 86 66 2 70 22 82 37 84 70 28 8 88 19 64 23 5 19 71 15 33 78 5 80 33 57 36 56 11 60 79 65 34 51 4 49 36 76 40 86 7 40 85 43 86 4 50 41 78 33 13 30 87 12 70 37 82 31 72 73 53 39

  • sefir14 |
    08/04/14
    sefir14

    bonjour comment faire la somme de chiffre et lettre dans excel 2007 exp dans la cellule A1=x A2=x A3=x/2 en fin dans la cellule A4 je veux obtenir une somme égal a 2.xp merci

  • kikou15 |
    27/04/14
    kikou15

    Bonjour, je voudrais trouver à partir d'un nombre et de son résultat, le programme de calcul est-ce possible ?

21/08/14
Votre avatar